Service disruption due global Google Cloud outage
Resolved
Jun 12 at 11:00pm CEST
Resolved. Learn more here: https://x.com/downdetector/status/1933309798604288219
Affected services
Pickup point selection
Created
Jun 12 at 08:00pm CEST
On June 12, 2025, at approximately 18:00 UTC, our app experienced a disruption lasting about 3 hours. This was caused by a global outage on Google Cloud Platform, which also impacted services such as Cloudflare and Shopify.
During this time, some users may have encountered issues using the app or noticed degraded functionality. The disruption was resolved by 21:00 UTC as upstream providers restored their services.
We’re reviewing measures to reduce the impact of similar upstream outages in the future. Thank you for your understanding and patience.
Affected services
Pickup point selection