Issue with orders being updated
Resolved
May 19 at 01:36pm CEST
This morning’s outage was traced to a small mismatch between our checkout extension and the order update engine, which caused new orders to stall. As soon as we identified the root cause, we shipped a targeted fix within 20 minutes and immediately began back-populating all missed order updates to ensure every pickup point selection was properly recorded. Moving forward, we’re strengthening our integration tests and real-time monitoring between these components to catch any discrepancies before they impact your customers. Thank you for your understanding, your trust, and your continued support as we work to make the app even more reliable.
Affected services
Locations API
Created
May 19 at 10:51am CEST
At 09:00 CEST today, we deployed the new app release—unfortunately, it introduced a bug that broke order updates for any storefront relying on order custom attribute or shipping address updates. We apologize for the disruption. By 10:45 CEST, we isolated and fixed the root cause. We’re now executing a backfill to update all impacted orders.
Affected services
Locations API